• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Bug Two bugs

#1
Hi,

I have found 2 bugs with this addon.

1. If the addon is enabled, when a user goes to login to the forum, the entire page gets whited out. To test, just make a fresh installation of Xenforo, install addon and logout. Then try logging in again.

2. The links being added do not work on any other view aside from the addons default. If you change the effect, the links don't show.

Thanks.
 

Dadparvar

Administrator
Staff member
License Validated
Resources Layouts [XF2]
Pricing Tables [XF2]
#2
Hi,

Thanks for reporting. We are in different time zone and now is monrning and I have court (as you may know my main job is for now my legal firm)

Afternoon I'll check and fix and update the add-on.

1. If the addon is enabled, when a user goes to login to the forum, the entire page gets whited out. To test, just make a fresh installation of Xenforo, install addon and logout. Then try logging in again.
I understood what you say and will check and fix it.

2. The links being added do not work on any other view aside from the addons default. If you change the effect, the links don't show.
Can you please explain it so that when I started checking it, I see what to check for this? Now I don't know how to reproduce the bug you found.
 
#3
Hi,

Thanks for reporting. We are in different time zone and now is monrning and I have court (as you may know my main job is for now my legal firm)

Afternoon I'll check and fix and update the add-on.


I understood what you say and will check and fix it.


Can you please explain it so that when I started checking it, I see what to check for this? Now I don't know how to reproduce the bug you found.
Hi,

No problem.

Add the links via the control panel and click save. You will now see the links you added in the navigation. However, if you change the behaviour of the navigation (right, top, left, etc) you will see that the links do not display. They will only display on the default view.

Thanks.
 
#4
TO ADD: It also completely breaks the UI.X addon by Audentio. I am currently using the Abyss theme and it is a no go for it.

Thanks.
 

Dadparvar

Administrator
Staff member
License Validated
Resources Layouts [XF2]
Pricing Tables [XF2]
#5
1. If the addon is enabled, when a user goes to login to the forum, the entire page gets whited out. To test, just make a fresh installation of Xenforo, install addon and logout. Then try logging in again.
OK. Found. And fixed.
2. The links being added do not work on any other view aside from the addons default. If you change the effect, the links don't show.
This bug doesn't exists. See the video I attached. I added some links. And then change the positions. I even change the themes. But it works fine. I even change list layout but again it works fine.
It also completely breaks the UI.X addon by Audentio. I am currently using the Abyss theme and it is a no go for it.
UI.X (and all their styles that uses UI.X framework) are so bad these days. By each update they add lots of new bugs and problems and they make huge changes from time to time. This makes developer's works a lot more than normal, and because of this, most of developers stopped supporting their products and even users started stopping using their products too. For example myself, after a lot of customizations on my Scratch style in my main site (other site - about law) finally stopped using it and purchased a new style (from Arty who is a professional designer) and also removed all my add-ons from Audentio from my site. (and maybe purchase from other person or develop them by myself) all my friends are going to do the same as what I did.
Recently I added support of UI.X to my Site Tour add-on (just because a few customers asked) but again after they updated their style I saw a problem came to my add-on and again one day of me went on adding support for their style! :confused: My works are mostly having some effects and graphic too. So when a style designer doesn't behave professionally, better not to support them. (they also never accept that the bug is from their style. In supporting UI.X in my Site Tour add-on, I found a few bugs in customer's style and asked him to report them to Audentio, and they said it is not a bug of style!!! So when they don't accept their fail, what we can do?)
Because of this, I prefer (yet) not to support their style. But anyway I'll try to improve the add-on today and add a few codes that may fix problem of UI.X, hope to be able to work with your custom style too. But I won't mention "Supporting UI.X" in update.
 

Attachments